Im Moment fühle ich mich ziemlich gestresst. Ich schlafe schlecht (mindestens bis 5 Uhr morgens wach und schlafe dann bis ca 14-15 Uhr), esse schlecht und darüber hinaus, muss ich mich nun auch noch um eine menge Papierkram kümmern mit Deadlines die mir halb das Genick brechen.

...Jedoch habe ich nun endlich ein Problem in meinem Netzwerk lösen können, was mich schon mehrere Wochen beschäftigte. Zugegeben, keine wirkliche Aufwiegelung der Dinge, die wirklich wichtig sind und um die ich mich kümmern muss, dennoch möchte ich im Detail darauf eingehen. Und wer bis hier hin gelesen hat und es noch nicht verstanden hat; ja, dies wird ein Technik-Post. Wer das jedoch trotzdem lesen mag, sei beruhigt, ich versuche es so einfach wie möglich zu erklären. :P

Meine Webseite, also damit auch mein Blog, läuft über mein Heimnetzwerk auf einem Raspberry Pi (nachfolgend nur noch "Raspi" genannt, der Faulheit wegen). Das ist ein so genannter "Ein-Platinen-Computer", nicht wirklich größer als eine Kreditkarte, kann kaum mit der Leistung eines Modernen Computers oder Smartphone mithalten, ist aber ideal für kleinere Aufgaben als Server, oder als Media-Server um z.B. mit seinem Fernseher Filme über das Internet oder externe Festplatte abspielen zu können, oder um Programmieren lernen zu können.

Der Aufgabenbereich meines Raspi ist ersteres. Und so läuft darauf neben einem Webserver auch ein Teamspeak-Server, ein IRC-Bouncer (IRC ist sowas wie knuddels (nur nicht so behindert) und der Bouncer hält meine Verbindung dorthin dauerhaft aufrecht), UND ein systemweiter Werbeblocker (Adblocker).

Und genau da lag auch das Problem, an diesem Adblocker. Im Normalfall regeln die Anfragen an Webseiten und Domains vorinstallierte Dienste auf einem Router und dem Internet-Anbieter. Diese Anfragen werden nun jedoch durch meinen Raspi mittels "Pi-Hole" geregelt und mit einer Liste für Werbung, Malware und anderem scheiß, den niemand haben will, gefiltert. Und das eben auf all meinen Geräten.

Nun eben auch nur im "Normalfall". Denn seit der Installation von Pi-Hole hatte ich innerhalb meines Netzwerkes keinen Zugriff mehr auf meine eigene Domain (also hypercrites.de), alle Anderen konnten nach wie vor auf alle meine Seiten zugreifen und ich ebenso, solange ich mich nicht in meinem eigenen Netzwerk befand. Ich wurde immer auf die Zertifikate (welche man braucht, um Webseiten mittels https betreiben zu können) von Google statt meinen, umgeleitet. Also begann die Fehlersuche...

Im ersten Anlauf habe ich Pi-Hole wieder deinstalliert, ohne Erfolg. Danach die Zertifikate erneuert, ohne Erfolg. Und weil mittlerweile selbst mein IRC-Bouncer nicht mehr wollte, habe ich sogar diesen neu installiert, was allerdings auch nichts brachte, außer noch mehr Aufwand. Danach habe ich mehrere male die Konfiguration meines Webservers abgeglichen (und aufgeräumt, was im nachhinein immerhin EINEN positiven Effekt hatte...), habe tagelang mit Foren und Github-Seiten (Das ist eine Bezugsquelle für viel Software und Code im Internet, dessen Quellcode man oft direkt einsehen kann) durchwälzt und bin letztendlich zu dem Entschluss gekommen, das Ganze erstmal auf sich beruhen zu lassen, bis ich neue Ideen hatte.

...Die ich dann nicht hatte. Also musste ich in den sauren Apfel beißen, und auf dem Github der Entwickler von Pi-Hole dann doch mal nach Hilfe fragen. Nach einer moderaten Wartezeit von ungefähr einem Tag, bekam ich dann auch endlich mal Rückmeldung und nach ein bisschen Hin und Her, screenshots und Tests um Fehler an verschiedenen Stellen auszuschließen, kam dann endlich eine Lösung zum vorschein!

Das Problem war, dass alle Anfragen von hypercrites.de auf eine Interne Adresse, bzw die von Google umgeleitet wurde. Zwei kleine Einträge in einer einzigen Datei. Wieso die Einträge dort vorhanden waren, weiß ich nicht, da ich die Datei zuvor nie angefasst habe. Jedoch wäre mir das auch nie aufgefallen, wenn meine Netzwerk-Anfragen nun nicht von meinem Raspi übermittelt werden würden, was auch erklärt, wieso man außerhalb Problemlos auf hypercrites.de zufreifen konnte, zum glück.

Nun läuft alles wieder wie es soll und mein Netzwerk ist werbefrei!!

Und ja, solche (kleinen) Dinge machen mich dann doch ein wenig glücklich, wenn sie denn funktionieren. Ist vielleicht ein bisschen seltsam, aber ich mag nun mal meinen Technikkrempel. Also, hier bin ich wieder, back in business, bitches!!